phpstudy_pro设置不同的composer版本和PHP版本


        起因是这样的,新项目需要PHP7.4,但是我win10系统的默认是7.3,而且死活都改不过来,只能说一句TND。那PHP版本不够有一些composer包就不能安装了,最后还是吧算盘打到了phpstudy的身上。

        

        但是这里的自带版本是1.8.5的composer,那就得自己升级一下吧。下面说说我是怎么配置的。


到安装目录复制一个composer1.8.5为新目录,并且重命名为composer2.3.10

再到  https://getcomposer.org/download/  下载最新的composer.phar


下载下来之后替换掉原来的文件


这样再从项目中打开composer的时候,就会有下拉选择了

完毕。


加评
支持QQ号码一键获取昵称,默认邮箱采用QQ邮箱。
评论(0)

暂无评论
快来留下你的脚印吧~